Categories


Tags


IIS 7.0 遇到Http 错误 404.17 Not Found 解决办法

当IIS 7.0遇到Http错误404.17 Not Found时,这表示服务器上没有启用所请求的文件类型的相应模块。 解决办法如下: 1. 打开IIS管理器,并定位到出错的网站或应用程序。 2. 双击“模块”功能视图,然后找到“静态文件”模块。如果该模块已禁用,请右键单击并选择“启用”。 3. 如果“静态文件”模块已启用,但仍然出现问题,请右键单击“静态文件”模块并选择“还原默认模块”。 4. 如果问题仍然存在,可能是因为IIS没有安装所请求文件类型的相应模块。您可以运行以下命令来安装所需的模块: %windir%\system32\inetsrv\appcmd.exe set config /section:system.webServer/handlers /+"[name='ExtensionName',path='*.extensionType',verb='GET,POST',modules='StaticFileModule',scriptProcessor='C:\Windows\System32\inetsrv\asp.dll',resourceType='Unspecified']" 在上述命令中,将“ExtensionName”替换为所需的文件扩展名(例如.aspx),将“extensionType”替换为文件的MIME类型(例如"text/html"),将“C:\Windows\System32\inetsrv\asp.dll”替换为适当的脚本处理程序路径。 退出并重新启动IIS,然后再次尝试访问网站或应用程序,应该能够解决问题。 这些步骤应该能够解决IIS 7.0遇到Http错误404.17 Not Found的问题。

Public @ 2023-07-28 19:00:34

防止ASP Session丢失的方法

1. 增加Session超时时间:可以在ASP应用程序的web.config配置文件中设置sessionState节点的timeout属性来增加Session超时时间。 2. 使用Cookie替代Session:将Session的数据存储到客户端的Cookie中,这样就不需要依赖服务器端的Session状态了。但是需要注意Cookie的安全性,以防止被篡改或盗取。 3. 少用Session:尽

Public @ 2023-04-28 02:50:09

access数据库常见问题处理

一,打开网站出现一直加载直到超时,或者提示数据库连接失败:这种多出现于数据库锁死,查看网站调用数据库目录存在.ldb文件(一般程序用了on error resume next语句,注释)。处理办法:(1)重启进程池。经常出现建议他联系程序提供商或开发人员 调试优化,或更换成mssql数据库,偶尔出现重启进程池/更换程序池。(2)一些网站代码本身有问题导致数据库一访问就锁死,处理办法是联系程序开发人

Public @ 2011-03-17 15:46:39

IIS子目录web.config与主站冲突解决方法

最近在项目中需要在应用中增加一个子目录的独立项目,项目需要配置在iis的根目录,结果配置成功之后,应用起不来了,出现错误提示,分析认为是web.config冲突造成的。IIS上在主站点下搭建虚拟目录后,子站点中的<system.web>节点与主站点的<system.web>冲突解决方法如下:在主站点的<system.web>上一级添加父节点:<locati

Public @ 2009-04-21 15:47:27

IIS实现反向代理

参考步骤: 1、使用IIS服务器部署后台程序,将程序部署至相对公网的虚拟主机,并供前端静态资源使用; 2、点击“模块”,启用http和proxy模块; 3、点击“反向代理”,为公网虚拟主机设置反代目标; 4、设置反代参数,如路径、请求头、cookie,等; 5、点击“站点”,为公网虚拟主机设置反代,将反代过来的地址映射到对应应用; 6、设置完毕后,重启IIS,应用反代设置,完成反向

Public @ 2023-02-24 19:48:19

更多您感兴趣的搜索

0.666292s