Categories


Tags


我司mysql对存储过程、视图、触发器,事件支持情况

我司mysql对存储过程、视图、触发器支持情况:

存储过程 支持

视图 支持

触发器 支持

事件 不支持

注意:建立存储过程和视图如需技术支持我司单独收费50元/次

如果是我司从mysql4.0升级到mysql5的数据库不支持存储过程、视图、触发器。

以下是一段建立存储过程代码实例:

DROP PROCEDURE IF EXISTS `createall`;

DELIMITER ;;

CREATE  PROCEDURE `createall`()

BEGIN

/*DROP TABLE DB2INST1.USR_INF;*/

CREATE TABLE USR_INF (USR_NBR INT,USR_NAM CHAR(60),USR_PWD INT,

REG_DAT DATE,PROFIT DECIMAL(13,2),USR_TYP CHAR(3),CON_TEL CHAR(20),CON_MOB CHAR(20),CLT_CNT INT,UPP_USR INT);

/*DROP TABLE DB2INST1.CLT_INF;*/

CREATE TABLE CLT_INF (CLT_NBR  INT  UNSIGNED PRIMARY KEY  AUTO_INCREMENT NOT NULL ,CLT_NAM CHAR(60),

CLT_ID CHAR(30),VIP_NO CHAR(30)

,VIP_TYP CHAR(20),SRV_USR INT,UPP_USR INT,ADM_USR INT,OTH_USR INT,REG_DAT DATE,BIR_DAT DATE,MAR_DAT DATE,SPO_DAT DATE,XML_INF VARCHAR(4096))AUTO_INCREMENT 1;

CREATE TABLE CLT_ACT (CLT_NBR INT,SUM_AMT DECIMAL(13,2),SUM_CNT INT,RTN_AMT DECIMAL(13,2)

,RTN_CNT INT,AVA_ACU INT,HIS_ACU INT);

CREATE TABLE CLT_TRX (CLT_NBR INT,TRX_AMT DECIMAL(13,2),TRX_ACU INT,TRX_DAT DATE,TRX_TIM TIME,

TRX_USR INT,PROFIT DECIMAL(13,2) );

CREATE TABLE CLT_NTC (CLT_NBR INT,NTC_TYP CHAR(3),NTC_MTD CHAR(10));

CREATE TABLE SYS_PAM (PAM_FAT CHAR(3),PAM_SUB CHAR(3),PAM_NAM CHAR(60));

CREATE TABLE PRD_LST (PRD_ID INT,BAR_COD CHAR(30),PRD_NAM CHAR(60),PRD_VAL DECIMAL(13,2),PRD_SEL DECIMAL(13,2),REG_DAT DATE);

/*DROP TABLE ERR_MSG;*/

CREATE TABLE ERR_MSG (MSG_ID INT,MSG_TXT CHAR(100));

END

;;

DELIMITER ;

以下是一段建立触发器代码的实例:

/*!50003 CREATE TRIGGER `del_authorize_and_user` AFTER DELETE ON `admin_role`

FOR EACH ROW begin

delete from authorize WHERE role_id=OLD.id;

delete from admin_user WHERE role_id=OLD.id;

delete from role_menu_droit WHERE role_id=OLD.id;

end */;;

DELIMITER ;

来源:西部数码


Public @ 2013-09-05 15:46:54

Mysql服务启动1067错误解决办法

Mysql服务启动1067错误是由于Mysql无法启动导致的。以下是可能的解决办法: 1. 检查Mysql日志,查找更多有关错误的详细信息:可以在Mysql安装目录下的data目录里查看。 2. 关闭防火墙或修改防火墙规则:可能是Mysql无法访问所需的端口造成的错误。 3. 修复或重建Mysql数据文件:可能是数据文件损坏导致的错误。 4. 检查Mysql配置文件是否正确:确保配置文件中

Public @ 2023-05-27 23:50:14

vps、弹性云手工附加MSSQL数据库(sqlserver2000版本)

首先将您的数据库mdf和ldf文件上传到服务器的某个目录(一般不要放在系统盘,以免系统损坏造成数据丢失),比如d:\mssql目录,并给该目录mssqluser的完全控制权限。注意,如果放在其他目录,务必保证该目录先加上mssqluser的完全控制权限,否则还原或备份会失败。保存备份的目录也必须有这个权限!!1、打开企业管理器,点击“安全性”--“登录”--“新建登录”,建立一个登录用户,如图:2

Public @ 2016-03-13 15:46:41

mysql导出备份、导入恢复以及迁移(适用虚拟主机)

推荐使用数据库管理软件进行操作,可以避免超时,同时支持大文件导入 使用mysql管理软件导入恢复/导出备份mysql一、备份源文件备份:1、虚拟主机管理--管理--数据库,点击备份mysql到databases目录4.jpg2、到文件管理里面选中database目录,然后点击压缩按钮进行压缩,再使用FTP连接空间下载压缩文件即可。4.jpg导出SQL文件备份1、虚拟主机管理--管理--数据库 点击

Public @ 2009-03-08 15:46:55

使用mysql管理软件导入恢复/导出备份mysql

利用mysql管理工具导入导出,可以避免数据导入导出时出现的乱码问题,mysql的管理软件有很多,文本主要介绍Navicat Premium的使用方法,软件可以去官方搜索下载。本文来源于互联网。注意:使用软件管理需要开启mysql的远程连接(不推荐使用root),我司虚拟主机默认支持远程连接如果您服务器未开启可以参考:vps、云主机、独立服务器mysql开启root远程宝塔面板开启远程可以参考:h

Public @ 2018-06-17 15:46:53

更多您感兴趣的搜索

0.405764s