Categories


Tags


SQL Server数据库提示

SQL Server数据库登陆时提示报错如图:

图片19.png

源错误 :

行 135:        </roleManager>

行 136: </system.web>

行 137: <system.serviceModel>

行 138:        <extensions>

行 139:                <behaviorExtensions>

源文件 : C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Config/machine.config    行 : 137

版本信息 :  Microsoft .NET Framework 版本 :2.0.50727.3053; ASP.NET 版本 :2.0.50727.3053

出现这个错误可能是机器重启的时候,配置文件中.NETFRAMEWORK3.0部分的控制运行配置并没有加进去,所以造成配置文件出错,这时只需要添加配置就可以了。

<sectionGroup name="system.serviceModel" type="System.ServiceModel.Configuration.ServiceModelSectionGroup, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">

<section name="behaviors" type="System.ServiceModel.Configuration.BehaviorsSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="bindings" type="System.ServiceModel.Configuration.BindingsSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="client" type="System.ServiceModel.Configuration.ClientSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="comContracts" type="System.ServiceModel.Configuration.ComContractsSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="commonBehaviors" type="System.ServiceModel.Configuration.CommonBehaviorsSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowDefinition="MachineOnly" allowExeDefinition="MachineOnly"/>

<section name="diagnostics" type="System.ServiceModel.Configuration.DiagnosticSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="extensions" type="System.ServiceModel.Configuration.ExtensionsSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="machineSettings" type="System.ServiceModel.Configuration.MachineSettingsSection, SMDiagnostics, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowDefinition="MachineOnly" allowExeDefinition="MachineOnly"/>

<section name="serviceHostingEnvironment" type="System.ServiceModel.Configuration.ServiceHostingEnvironmentSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="services" type="System.ServiceModel.Configuration.ServicesSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

</sectionGroup>

<sectionGroup name="system.serviceModel.activation" type="System.ServiceModel.Activation.Configuration.ServiceModelActivationSectionGroup, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">

<section name="diagnostics" type="System.ServiceModel.Activation.Configuration.DiagnosticSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="net.pipe" type="System.ServiceModel.Activation.Configuration.NetPipeSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

<section name="net.tcp" type="System.ServiceModel.Activation.Configuration.NetTcpSection, System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

</sectionGroup>

将以上内容添加到C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Config/machine.config文件中的configSections之间就可以了。

重新打开SQL Server数据库测试数据库已经正常登陆,未再出现相关报错。

来源:景安


Public @ 2019-05-16 15:47:44

SQL Server的Inner Join及Outer Join

在一个正规化的数据库环境中, 我们常会碰到这款情形: 所需的资料并不是放在同一个资料表中, 在这个时候, 你就要用到 Join当然 Join 如何将不同的数据库的资料结合, 还要看你如何使用它, 一共有四种不同的 Join 的方式, 在这篇文章中我们将为你介绍 Inner Join 及 Outer Join 以及其应用Inner JoinInner Join 应该是最常用的 Join 方式, 它只

Public @ 2020-12-14 15:47:51

独立服务器win2003系统站点常见问题解答

独立服务器win2003系统站点常见问题解答问题1:未启用父路径症状举例:Server.MapPath() 错误 ASP 0175 : 80004005不允许的 Path 字符/0709/dqyllhsub/news/OpenDatabase.asp,行 4在 MapPath 的 Path 参数中不允许字符 ..。原因分析:许多Web页面里要用到诸如../格式的语句(即回到上一层的页面,也就是父路

Public @ 2016-04-30 16:13:23

SQL Server 2008R2数据库不允许保存更改的解决办法

一、问题描述SQL Server 2008R2数据库在修改表结构的时候出现警告【不允许保存更改。您所做的更改要求删除并重新创建以下表。您对无法重新创建的标进行了更改或者启用了“阻止保存要求重新创建表的更改"选项。】图片15.png二、解决步骤1.点击SQL2008菜单  工具—》选项图片16.png2. 打开了选项对话框,展开Designers,单击【表设计器和数据库设计器】,

Public @ 2019-08-10 15:47:46

三种数据库利用SQL语句进行高效果分页

在程序的开发过程中,处理分页是大家接触比较频繁的事件,因为现在软件基本上都是与数据库进行挂钓的。但效率又是我们所追求的,如果是像原来那样把所有满足条件的记录全部都选择出来,再去进行分页处理,那么就会多多的浪费掉许多的系统处理时间。为了能够把效率提高,所以现在我们就只选择我们需要的数据,减少数据库的处理时间,以下就是常用SQL分页处理:1、SQL Server、Access数据库这都微软的数据库,都

Public @ 2010-02-01 15:47:53

更多您感兴趣的搜索

0.534852s