Categories


Tags


大数据量下快速获取 SQL Server 数据库表记录数的方法

在数据库应用的设计中,我们往往会需要获取某些表的记录总数,用于判断表的记录总数是否过大,是否需要备份数据等。我们通常的做法是:select count(*) as c from tableA 。然而对于记录数巨大的表,上述做法将会非常耗时。在DELL 4400 服务器上做试验,MS Sqlserver 2000 数据库对于100万记录的简单数据表执行上述语句,时间在1分钟以上。如果在表的某个字段上做聚簇索引,第一次执行该语句的时间和没有索引的时间差不多,之后执行上述语句,速度很快,在1秒中以内,但当表的记录数发生较大变化后,再执行该语句又会经历一次耗时的过程。而且不是每个表都适合做聚簇索引的,对于数量巨大的表,如果需要经常增删操作,建聚簇索引是一个很不明智的做法,将会极大的影响增删的速度。那么有没有一个比较简单的方法快速获取表的记录总数呢?答案是有的。

在MS SQL 数据库中每个表都在sysindexes 系统表中拥有至少一条记录,该记录中的rows 字段会定时记录表的记录总数。

下面是sysindexes 表的相关记录的含义:

列名 数据类型 描述

id int 表ID(如果 indid = 0 或255)。否则为索引所属表的ID

Indid smallint 索引ID:

0=表

1=聚簇索引

>1=非聚簇索引

255=具有text或image数据的表条目。

rows int 基于indid=0 和 indid=1地数据级行数,该值对于indid>1重 复。如果indid=255,rows设置为0。

当表没有聚簇索引时,Indid = 0 否则为 1。

那么现在大家应该知道如何获取表的记录总数了,只需执行如下语句:

select rows from sysindexes where id = object_id(tablename) and indid in (0,1)

该方法获取表的记录总数的速度非常快,在毫秒级就可以完成,相比select count(*) 要快上数万倍,但是大家在运用该方法是一定要主要,该方法得到的表的总记录数不是一个精确值,原因是MS SQL 并不是实时更新该字段的值,而是定时更新,当从实践来看该值和精确值一般误差不大,如果你希望快速的粗略估算表的大小,建议你采用该方法。如果你希望得到精确值,那么请在执行上述语句前执行DBCC UpdateUSAGE(DatabaseName,[TABLENAME]) WITH ROW_COUNTS 强制更新该字段的值,但这样第一次更新时会耗费大量的时间,这样做的效果和建有聚簇索引的表 select count (*) 效果相差不大,所以如果你希望相对快速地得到精确的表的记录总数,那么你有两种选择,建聚簇索引或者先DBCC 再使用上述方法。

文/安娜 出处/赛迪网

来源:月光博客


Public @ 2013-09-15 15:47:54

Windows Server的IIS和Apache性能

比较 IIS在某些情况下会优于Apache,因为IIS是一款微软设计的Web服务器,适应Windows操作系统,而Apache是一个跨平台的Web服务器,这也会使IIS在某些情况下有更好的性能。同时,IIS有几个性能优化器,可以使用这些性能优化器来提高IIS的性能。另一方面,Apache的性能依赖于其可拓展的模块,要在Apache上获得更好的性能,使用者可以安装一些可拓展模块来提高性能。然而,在

Public @ 2023-02-24 21:00:19

访问网站提示:您未被授权查看该页恢复办法

如果您在访问网站时收到“您未被授权查看该页”的提示,可能是因为该页面需要特定的权限或登录状态才能访问。以下是一些可能的解决方案: 1. 确认是否已登录:如果该网站需要登录才能查看内容,请确保您已经登录到您的账户中。如果您尚未登录,则尝试登录并重新访问该页面。 2. 检查权限:如果您已经登录但仍无法查看该页面,则可能需要特定的权限才能查看该页面内容。请检查您的账户权限并查看是否需要申请更高级别的

Public @ 2023-03-29 18:00:23

SQL Server数据库启动报错1068解决办法

1、运行sqlcmd,执行下面命令 EXEC xp_readerrorlog 0, 1, N' Socket 9.x.x.x', NULL, NULL, N'ASC' 2、记下当中的出错消息,通常以“Login failed for user”,来帮助定位出问题所在 3、如果该问题和SQL Server的日志连接有关,可以通过以下命令来查看是否存在该日志连接: SELE

Public @ 2023-03-01 07:00:18

SQL Server 2005数据库修改sa密码的方法

: 1、先登录SQL Server里的数据库服务器,使用Window Authentication登录,以Administrator权限运行SQL Server Management Studio,然后右键点击SQL Server实例,选择属性,这时候会弹出一个对话框,点击安全页,在用户名一栏找到sa用户,点击右侧的password修改栏,然后再新密码一栏输入密码即可。 2、使用SQL脚本修改

Public @ 2023-02-26 12:00:21

更多您感兴趣的搜索

0.417316s