Categories


Tags


大数据量下快速获取 SQL Server 数据库表记录数的方法

在数据库应用的设计中,我们往往会需要获取某些表的记录总数,用于判断表的记录总数是否过大,是否需要备份数据等。我们通常的做法是:select count(*) as c from tableA 。然而对于记录数巨大的表,上述做法将会非常耗时。在DELL 4400 服务器上做试验,MS Sqlserver 2000 数据库对于100万记录的简单数据表执行上述语句,时间在1分钟以上。如果在表的某个字段上做聚簇索引,第一次执行该语句的时间和没有索引的时间差不多,之后执行上述语句,速度很快,在1秒中以内,但当表的记录数发生较大变化后,再执行该语句又会经历一次耗时的过程。而且不是每个表都适合做聚簇索引的,对于数量巨大的表,如果需要经常增删操作,建聚簇索引是一个很不明智的做法,将会极大的影响增删的速度。那么有没有一个比较简单的方法快速获取表的记录总数呢?答案是有的。

在MS SQL 数据库中每个表都在sysindexes 系统表中拥有至少一条记录,该记录中的rows 字段会定时记录表的记录总数。

下面是sysindexes 表的相关记录的含义:

列名 数据类型 描述

id int 表ID(如果 indid = 0 或255)。否则为索引所属表的ID

Indid smallint 索引ID:

0=表

1=聚簇索引

>1=非聚簇索引

255=具有text或image数据的表条目。

rows int 基于indid=0 和 indid=1地数据级行数,该值对于indid>1重 复。如果indid=255,rows设置为0。

当表没有聚簇索引时,Indid = 0 否则为 1。

那么现在大家应该知道如何获取表的记录总数了,只需执行如下语句:

select rows from sysindexes where id = object_id(tablename) and indid in (0,1)

该方法获取表的记录总数的速度非常快,在毫秒级就可以完成,相比select count(*) 要快上数万倍,但是大家在运用该方法是一定要主要,该方法得到的表的总记录数不是一个精确值,原因是MS SQL 并不是实时更新该字段的值,而是定时更新,当从实践来看该值和精确值一般误差不大,如果你希望快速的粗略估算表的大小,建议你采用该方法。如果你希望得到精确值,那么请在执行上述语句前执行DBCC UpdateUSAGE(DatabaseName,[TABLENAME]) WITH ROW_COUNTS 强制更新该字段的值,但这样第一次更新时会耗费大量的时间,这样做的效果和建有聚簇索引的表 select count (*) 效果相差不大,所以如果你希望相对快速地得到精确的表的记录总数,那么你有两种选择,建聚簇索引或者先DBCC 再使用上述方法。

文/安娜 出处/赛迪网

来源:月光博客


Public @ 2013-09-15 15:47:54

windows系统防火墙开启放行其他端口

(1)打开“防火墙”界面:右击最右下角的Win按键,打开它,选择“设置”→“更多设置”→“更多”→“防火墙”; (2)在“Windows防火墙”界面点击“允许一个应用程序或功能通过防火墙”; (3)点击“更改设置”,把新建的“运行授权流程”选中,然后点击“允许此功能”; (4)点击“添加端口”,输入想要开放的端口及相关说明,选择它的类型,“TCP或UDP”,再选择“作为本机地址”和“是否

Public @ 2023-02-25 11:12:22

快云服务器使用文档

一、购买方式1)登陆快云官网:https://www.kuaiyun.cn/图片24_副本.png2)选择--产品--快云服务器图片25_副本.png2,选择配置并购买1)在新页面选择立即购买图片26_副本.png2)选择配置类型,机房位置,数据盘容量,带宽后点击下一步选择时长与镜像图片27_副本.png3)选择时长和系统的版本,点击立即购买。图片28_副本.png4)在购物车页面点击支付即可完成

Public @ 2010-08-09 16:13:13

SQL Server 2008数据库安装提示重启错误

1.安装sql server 2008,提示重启失败,于是重启电脑,再次安装还是提示重启失败,来回反复,重启好多回,问题依旧。图片42.png2.命令regedit,打开注册表图片43.png3.找到HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server目录。图片44.png右键选择删除图片45.png图片46.png4.找到HKEY_

Public @ 2010-04-03 15:47:45

更改SQL Server 2005数据库端口方法

1.如果服务器的TCP端口更改为其他的端口,那么在客户端的配置工具中需要做如下的设置:程序->Microsoft sql server 2005 ->配置工具->sql server configration manage ,如下图:图片31.png2.在网络配置中选择SQLEXPRESS协议如下图所示:图片32.png3.在右侧的TCP/IP中的属性中,协议对话框的内容,按照如

Public @ 2012-03-02 15:47:48

更多您感兴趣的搜索

0.656266s