Categories


Tags


Windows Server的IIS和Apache性能

我曾经在《Windows服务器下的IIS和Apache性能比较》一文中比较了IIS和Apache的一些性能比较,并实际搭建了一个Apache+MySQL+PHP的平台,我当时的初步比较是两者在静态HTML的处理能力上基本相同。

但是,经过我在实际网站上运行Apache+MySQL+PHP一段时间后,我发现在Windows Server 2003的环境下,Apache 2.2.6的稳定性的确不如IIS6,在动态文件处理能力上也不足,内存的消耗量却远远高于IIS,以至于将系统配置为《在Windows Server下集成Apache、Tomcat和IIS》的时候,Apache会影响IIS的并发处理能力。

因此,在Windows Server 2003的环境下还是使用IIS6更为稳定,IIS同样也可以支持PHP和MySQL,配置方法是,在IIS的“WEB服务扩展”中,添加一个新的WEB服务扩展,程序后缀为PHP,ISAPI程序为php5isapi.dll,然后再“环境变量”-“系统变量”中增加变量名PHPRC,数值为php.ini的路径,重启服务器即可。

这样搭建的系统也可以支持WordPress等等流行的PHP程序,可惜不支持mod_rewrite,使用一些第三方的插件才能支持类似Apache的mod_rewrite功能。

新搭建的IIS+MySQL+PHP系统我还会观察一段时间,看看整体性能和稳定性是否比Apache好一些。

来源:月光博客


Public @ 2021-12-12 16:01:02

清理网站挂马代码(适用vps云主机服务器)

VPS/云主机若发现被挂马,请立即上服务器停止您的IIS或apache,为避免您对网站程序不熟悉导致误清理,请联系您的网站开发人员登录服务器处理。清理方法(以下操作有风险,建议备份好数据并联系网站开发人员处理!):首先下载一个文本替换专家,http://download.myhostadmin.net/%E7%B3%BB%E7%BB%9F%E5%B7%A5%E5%85%B7/%E6%96%87%E

Public @ 2012-08-06 16:13:27

windows 2003 64位系统php运行报错:1% 不是有效的 win32 应用程序

问题一:php运行报错:1% 不是有效的 win32 应用程序php环境配置完毕后,运行html成功,但运行php就报错,错误提示是“1% 不是有效的 win32 应用程序”,英文报%1 is not a valid Win32 application。第一次碰到这样的问题,经过搜索和试验,问题终于解决。报错原因:由于在64位操作系统里,默认配置下,IIS工作在64位模式下,这会让许多32位的应用

Public @ 2018-05-05 15:47:15

[原创]取消Ubuntu系统意外关机后停留在GRUB界面的解决办法

现象:Ubuntu意外断电关机重启进入GRUB引导界面不动,必须手动回车后才能进系统。原因:查看 /boot/grub/grub.cfgif [ "${recordfail}" = 1 ]; thenset timeout=-1elseset timeout=2正是被这个-1给停留到启动界面的解决办法:先将/boot/grub/grub.cfg 默认只读修改为可写入cd /bo

Public @ 2015-01-28 15:47:16

更多您感兴趣的搜索

0.439956s