Categories


Tags


windows系统MySQL 5.7 解压缩版安装配置方法

1. 下载MySQL 5.7解压缩版,解压到本地磁盘。 2. 定位到MySQL解压缩目录下面的bin目录,打开该目录。 3. 在bin目录下创建一个my.ini文件,用来配置MySQL属性。 4. 打开my.ini文件,写入以下内容,其中basedir和datadir的路径需要根据你的自己的安装目录进行配置。 [mysql] # 设置mysql客户端默认字符集 default-character-set=utf8 [mysqld] # 设置3306端口 port=3306 # 设置mysql的安装目录 basedir=D:\MySQL-5.7 # 设置mysql数据库的数据的存放目录 datadir=D:\MySQL-5.7\data # 允许最大连接数 max_connections=200 # 允许连接失败的次数。 max_connect_errors=10 # 服务端使用的字符集默认为UTF8 character-set-server=utf8 # 创建新表时将使用的默认存储引擎 default-storage-engine=INNODB # 可以打开同一时间的最大表数量 table_open_cache=64 # 线程池中的线程数量 thread_pool_size=4 # 需要将sql_mode设置成空,否则不允许插入空的日期或者是时间 sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES 5. 启动MySQL服务,打开bin目录下的Command Prompt窗口,输入以下命令启动MySQL服务。 > mysqld.exe -console 注意:如果你是在Windows系统的服务中启动MySQL服务的话需要先在命令行启动,否则可能会出现服务启动失败的问题。 6. 设置MySQL的root账号密码。 在bin目录下打开另外一个Command Prompt窗口,输入下面的指令: > mysql -u root 进入mysql之后,输入以下命令来修改root的密码。 > ALTER USER 'root'@'localhost' IDENTIFIED BY 'newpassword'; 注意:newpassword需要换成你自己的密码。 7. 安装成功后,可以通过以下命令进行卸载: > mysqld.exe -remove 至此,MySQL 5.7解压缩版的安装配置就完成了。

Public @ 2023-04-06 14:00:54

源文件方式恢复mysql数据库(适用虚拟主机、云主机)

Mysql数据库转移有很多种处理办法,总结起来也就是两种,一种是用sql语句,这个方式是通用的(http://www.west.cn/faq/list.asp?unid=875  ),另外一种就是用源文件,最简单便捷的无疑是直接用数据库源文件来恢复,但这个前提是数据库版本要一致,否则会出现乱码(4.0与5.0版本的不兼容),所以用源文件恢复时一定要弄清楚mysql的版本。数据库源文件后缀

Public @ 2016-07-01 15:46:53

mysql导出备份、导入恢复以及迁移(适用虚拟主机)

推荐使用数据库管理软件进行操作,可以避免超时,同时支持大文件导入 使用mysql管理软件导入恢复/导出备份mysql一、备份源文件备份:1、虚拟主机管理--管理--数据库,点击备份mysql到databases目录4.jpg2、到文件管理里面选中database目录,然后点击压缩按钮进行压缩,再使用FTP连接空间下载压缩文件即可。4.jpg导出SQL文件备份1、虚拟主机管理--管理--数据库 点击

Public @ 2009-03-08 15:46:55

自动备份mysql并删除7天前备份

可以使用脚本实现自动备份mysql和删除过期备份的功能。 以下是一个使用bash脚本实现自动备份mysql和删除7天前备份的例子: ``` #!/bin/bash # MySQL参数 USER="root" # 修改为你的MySQL用户名 PWD="password" # 修改为你的MySQL密码 HOST="localhost" # 修改为你的MySQL主机地址 DBNAME="db

Public @ 2023-04-23 13:50:32

更多您感兴趣的搜索

0.427777s