Categories


Tags


windows系统MySQL 5.7 解压缩版安装配置方法

1. 下载MySQL 5.7解压缩版,解压到本地磁盘。 2. 定位到MySQL解压缩目录下面的bin目录,打开该目录。 3. 在bin目录下创建一个my.ini文件,用来配置MySQL属性。 4. 打开my.ini文件,写入以下内容,其中basedir和datadir的路径需要根据你的自己的安装目录进行配置。 [mysql] # 设置mysql客户端默认字符集 default-character-set=utf8 [mysqld] # 设置3306端口 port=3306 # 设置mysql的安装目录 basedir=D:\MySQL-5.7 # 设置mysql数据库的数据的存放目录 datadir=D:\MySQL-5.7\data # 允许最大连接数 max_connections=200 # 允许连接失败的次数。 max_connect_errors=10 # 服务端使用的字符集默认为UTF8 character-set-server=utf8 # 创建新表时将使用的默认存储引擎 default-storage-engine=INNODB # 可以打开同一时间的最大表数量 table_open_cache=64 # 线程池中的线程数量 thread_pool_size=4 # 需要将sql_mode设置成空,否则不允许插入空的日期或者是时间 sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES 5. 启动MySQL服务,打开bin目录下的Command Prompt窗口,输入以下命令启动MySQL服务。 > mysqld.exe -console 注意:如果你是在Windows系统的服务中启动MySQL服务的话需要先在命令行启动,否则可能会出现服务启动失败的问题。 6. 设置MySQL的root账号密码。 在bin目录下打开另外一个Command Prompt窗口,输入下面的指令: > mysql -u root 进入mysql之后,输入以下命令来修改root的密码。 > ALTER USER 'root'@'localhost' IDENTIFIED BY 'newpassword'; 注意:newpassword需要换成你自己的密码。 7. 安装成功后,可以通过以下命令进行卸载: > mysqld.exe -remove 至此,MySQL 5.7解压缩版的安装配置就完成了。

Public @ 2023-04-06 14:00:54

独立主机/VPS的IIS和MYSQL 停止和启动方法

IIS服务的启动与停止:点击开始--运行,可以通过命令来实现对IIS的控制:iisreset 重启IIS服务iisreset /stop 停止IIS服务iisreset /start 启动IIS服务mysql服务的启动与停止:点击开始--运行,输入services.msc ,在弹出的服务窗口中,找到mysql服务,直接点击左侧对应的就可以了。也可以用命令的方式重启,方法与IIS的命令方法相似:ne

Public @ 2021-11-27 15:47:18

access数据库常见问题处理

一,打开网站出现一直加载直到超时,或者提示数据库连接失败:这种多出现于数据库锁死,查看网站调用数据库目录存在.ldb文件(一般程序用了on error resume next语句,注释)。处理办法:(1)重启进程池。经常出现建议他联系程序提供商或开发人员 调试优化,或更换成mssql数据库,偶尔出现重启进程池/更换程序池。(2)一些网站代码本身有问题导致数据库一访问就锁死,处理办法是联系程序开发人

Public @ 2011-03-17 15:46:39

mysql导出备份、导入恢复以及迁移(适用虚拟主机)

推荐使用数据库管理软件进行操作,可以避免超时,同时支持大文件导入 使用mysql管理软件导入恢复/导出备份mysql一、备份源文件备份:1、虚拟主机管理--管理--数据库,点击备份mysql到databases目录4.jpg2、到文件管理里面选中database目录,然后点击压缩按钮进行压缩,再使用FTP连接空间下载压缩文件即可。4.jpg导出SQL文件备份1、虚拟主机管理--管理--数据库 点击

Public @ 2009-03-08 15:46:55

更多您感兴趣的搜索

0.527303s